Macports Cmake with Outdated Frameworks

Cmake always got failed when upgrading macports:

In that cmake/main.log:

These symbols must be from libcurl or other similar name, the only possible one in macports is ‘curl‘, which, I tried, is not the solution.

More in that log file:

This libcurl.framework is not introduced by Xcode 5 or 6, in fact, I don’t know why they are there.

Those libxxx.framework-s were created at June 21, I can’t tell what might happen that day or those days.
I tried to file it:

ppc_7400

I mkdir-ed an ‘old’, and moved all those libxxx.framework-s to that folder, retried port install cmake, then it worked.

Macports Cmake with Outdated Frameworks by @sskaje: https://sskaje.me/2014/10/macports-cmake-outdated-frameworks/